Support for Visual Studio 2013 and later?

Oct 17, 2013 at 12:16 PM
Are there any plans to support Visual Studio 2013 and later versions?
Developer
Oct 17, 2013 at 12:19 PM
Yes, definitely, the work is already done against VS2013 RC so it should be a matter of days before I can verify against the final VS2013 RTM version and publish the new release.
Oct 17, 2013 at 12:20 PM
Thx. Good to hear.
Oct 18, 2013 at 8:33 AM
Eagerly waiting for your update jelled so that I can proceed with upgrading LASG as well :)

Hugs,
Serena
Developer
Oct 18, 2013 at 8:05 PM
Edited Oct 18, 2013 at 8:12 PM
The VS2013 RTM version is now available!

Note that both the package id and version have changed so you'll have to update your vsixmanifest file accordingly. The package id now includes the target Visual Studio version (i.e. "OpenGAX-VS2013") and the version has been reset to 1.0 since it's basically the first version for VS 2013.

Cheers,

Jelle
Oct 21, 2013 at 5:33 AM
What is the story regarding backward compatibility? Does an updated package support VS2013 and VS2012 or do I have to maintain two versions using different GAX versions?
Developer
Oct 21, 2013 at 7:05 AM
For the moment I'm using a separate package id per version of Visual Studio to avoid any side-by-side issues, so you'd indeed have to maintain a version per target VS version.

I think at one point I tried to support the same package id but failed (although I'm not sure anymore to be honest). So feel free to test out the impact of reusing the same package id across VS versions and see if everything keeps working. If the restriction can be safely removed, I'm happy to change the approach.